Перейти к содержимому

- - - - -

DLE-Forum 2.4 (уязвимости)


Изображение


В DLE Forum 2.4 есть уязвимость, которая позволяет выполнять запросы в бд, и узнавать любую инфу, например о логинах и о паролях.
У кого стоит данная версия форума, рекомендуется проверить на уязвимость:
ваш_сайт.ру/?do=forum&showtopic=-1+union+select+1,2,CONCAT_WS(0x3a,name,password),4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23+from+dle_users+where+user_group=1+limit+1-- ,
Если ВАш сайт уязвим, то в заголовке страницы будет отображен логин, и хеш пароля.
Уязвимость находится в скрипте engine/forum/sources/components/init.php в 446 строке!
if ($_REQUEST['category'])
{
$act = 'category';$cid =$_REQUEST['category'];
 
$t_act = '?c'.$cid;
}
if ($_REQUEST['showforum'])
{
$act = 'forum';
 
$fid = $_REQUEST['showforum'];
 
$t_act = '?f'.$fid;
}
 
if ($_REQUEST['showtopic'])
{
$act = 'topic';
 
$tid = $_REQUEST['showtopic'];
 
$t_act = '?t'.$tid;
}

Данный код необходимо заменить на:
if ($_REQUEST['category'])
{
$act = 'category';
$cid = intval($_REQUEST['category']);
$t_act = '?c'.$cid;
}
if ($_REQUEST['showforum']) 
{
$act = 'forum';
 
$fid = intval($_REQUEST['showforum']);
$t_act = '?f'.$fid;
}
if ($_REQUEST['showtopic'])
{
$act = 'topic';
$tid = intval($_REQUEST['showtopic']);
$t_act = '?t'.$tid;
}

  • NastiaUsam, KolleginWams, ZenitFCer и 24 другим это нравится


0 Comments

Яндекс.Метрика Рейтинг@Mail.ru
Besucherzahler femmes russes a marier
счетчик посещений