Перейти к содержимому

- - - - -

ПОТЕНЦИАЛЬНАЯ УГРОЗА В DLE 8.5 - 10.0


Изображение


Проблема: Недостаточная фильтрация данных в модуле сжатия файлов Minify входящем в состав DLE (https://code.google.com/p/minify/), которая может позволить при определенных настройках серверного ПО читать содержимое файлов.

Ошибка в версии: 8.5 - 10.0
Степень опасности: Высокая

Для исправления откройте файл: /engine/classes/min/index.php и в самое начало файла после строчки:
<?php
добавьте:
PHP:
if (isset($_GET['f'])) { 
       $_GET['f'] = str_replace(chr(0), '', (string)$_GET['f']); 
}
Подробнее:
http://dle-news.ru/bags/v10/1580-potencialnaya-ugroza-v-module-minify.html
Хочется отметить, что это угроза не в самом ДЛЕ, а в используемой сторонней библиотеки Minify. Если Вы используете Minify на своих сайтах, следует сделать обновление на новую версию (https://code.google..../downloads/list).


0 Comments

Яндекс.Метрика Рейтинг@Mail.ru
Besucherzahler femmes russes a marier
счетчик посещений